Жалоба Admins Team

Статус
В этой теме нельзя размещать новые ответы.

4el0ve4ik

Жыве Беларусь!
Всефорумный модератор
1,503
1,072
Ты что, нельзя, ведь авто-обновление скрипта - по любому будет без стиллера. Можно пропускать. А вот в либы наоборот у меня цель была стиллеры залить. Ты че, сразу не додумался?)
В общем не знаю, почему никто другой тебе не расписал причину по которой мы решили разрешить оставлять только ссылки на офф репозитории библиотек.
Суть такая: это все делается не из-за стиллеров, все делается из-за того, что бы избежать конфликтов между скриптами.
Привожу простой пример:
один скрипт использует библиотеку версии 1.5
ты устанавливаешь скрипт с которым в архиве идет либа версии 1.3, в которой нет нужного функционала для первого скрипта.
итог: юзвер идет в тему с первым скриптом, пишет "А У МИНЯ НИРАБОТАИТ" и мы имеем +100500 таких тем, а виной всему архив библиотек который заливают люди к своим скриптам.
А теперь давай представим, что каждый автор будет заливать библиотеки к своим скриптам, с течением времени он сам наебнет свои первые скрипты.
Отнесись с пониманием, организуй подкачку с офф репозиториев или просто оставь ссылки на офф репозитории библиотек.
 

СоМиК

Активный
Автор темы
188
28
В общем не знаю, почему никто другой тебе не расписал причину по которой мы решили разрешить оставлять только ссылки на офф репозитории библиотек.
Суть такая: это все делается не из-за стиллеров, все делается из-за того, что бы избежать конфликтов между скриптами.
Привожу простой пример:
один скрипт использует библиотеку версии 1.5
ты устанавливаешь скрипт с которым в архиве идет либа версии 1.3, в которой нет нужного функционала для первого скрипта.
итог: юзвер идет в тему с первым скриптом, пишет "А У МИНЯ НИРАБОТАИТ" и мы имеем +100500 таких тем, а виной всему архив библиотек который заливают люди к своим скриптам.
А теперь давай представим, что каждый автор будет заливать библиотеки к своим скриптам, с течением времени он сам наебнет свои первые скрипты.
Отнесись с пониманием, организуй подкачку с офф репозиториев или просто оставь ссылки на офф репозитории библиотек.
У меня проверка идет по названию файла, а не по коду в нем, что говорит о том, что если у юзвера уже будет либа версии 1.5, а скрипту нужна будет 1.3, скрипт просто выдаст ошибку, а не будет пытаться переустановить либу. А это значит лишь то, что скрипт НИКОГДА с другими скриптами из-за подкачки либов конфликтовать не будет. Соответственно правил я и не нарушаю. Надеюсь отнесетесь с пониманием и разблокируете тему.


1631026572105.png
 
  • Bug
Реакции: paulohardy

Двойной стандарт

Известный
242
105
У меня проверка идет по названию файла
Ты не понял
ты качаешь со своей репы
То есть, например, сейчас samp.lua версии 2.3, ты скачал его и закинул в свой репозиторий и заставляешь скачивать оттуда же, но выходит версия 2.4, которая конфликтует с 2.3 и все перешли на 2.4. А ты, например, не заметил этого и поддерживаешь скрипт под версию 2.3.
Поэтому тебе говорят, сделай автоскачивание с официального репозитория.
 

PanSeek

аче)
Модератор
663
816
Надеюсь отнесетесь с пониманием и разблокируете тему.
Мы и не блокировали тему, а отправили на модерацию.

Вот ваш репозиторий с библиотеками: https://github.com/SoMiK3/FastLinkLibs
То есть, он один и он не изменяется, а при обновлении библиотек - вы будто будете следить и изменять их?

Оригинальные библиотеки:
vector3d & vkeys - уже имеется в самом MoonLoader'е
SAMP.Lua - https://github.com/THE-FYP/SAMP.Lua
ImGui - https://www.blast.hk/moonloader/files/misc/moon-imgui-1.1.5.zip (он в принципе не обновляется, так что можно оставить как есть - думаю ничего страшного)
 

DonHomka

1000-7
Всефорумный модератор
3,939
3,458
Переделаешь на официальные репозитории?
 

СоМиК

Активный
Автор темы
188
28
Мы и не блокировали тему, а отправили на модерацию.

Вот ваш репозиторий с библиотеками: https://github.com/SoMiK3/FastLinkLibs
То есть, он один и он не изменяется, а при обновлении библиотек - вы будто будете следить и изменять их?

Оригинальные библиотеки:
vector3d & vkeys - уже имеется в самом MoonLoader'е
SAMP.Lua - https://github.com/THE-FYP/SAMP.Lua
ImGui - https://www.blast.hk/moonloader/files/misc/moon-imgui-1.1.5.zip (он в принципе не обновляется, так что можно оставить как есть - думаю ничего страшного)
1631029939760.png



теперь пропустят?
Переделаешь на официальные репозитории?
 

DonHomka

1000-7
Всефорумный модератор
3,939
3,458
Ну я в очень скором времени (сегодня - завтра) выпущу апдейт 2.1, в котором как раз изменятся ссылки на репозиторий, так что если пропустят - да
ну вот зальешь с измененными ссылками - пропустят
 
Статус
В этой теме нельзя размещать новые ответы.